如何配置Cisco交换机的IP地址

大家知道如何配置Cisco交换机的IP地址的方法么?接下来是小编为大家收集的如何配置Cisco交换机的IP地址方法,希望能帮到大家。  如何配置Cisco交换机的IP地址的方法  1. 计算机命令: 

大家知道如何配置Cisco交换机的IP地址的方法么?接下来是小编为大家收集的如何配置Cisco交换机的IP地址方法,希望能帮到大家。

  如何配置Cisco交换机的IP地址的方法

  1. 计算机命令:

  PCA login: root ;使用root用户

  password: linux ;口令是linux

  # shutdown -h now ;同init 0 关机

  # logout

  # login

  # ifconfig ;显示IP地址

  # ifconfig eth0 netmask ;设置IP地址

  # ifconfig eht0 netmask down ; 删除IP地址

  # route add 0.0.0.0 gw

  # route del 0.0.0.0 gw

  # route add default gw ;设置网关

  # route del default gw ;删除网关

  # route ;显示网关

  # ping

  # telnet

  2. 交换机支持的命令:

  交换机基本状态:

  switch: ;交换机的ROM状态

  rommon> ;路由器的ROM状态

  hostname> ;用户模式

  hostname# ;特权模式

  hostname(config)# ;全局配置模式

  hostname(config-if)# ;接口状态

  交换机口令设置:

  switch>enable ;进入特权模式

  switch#config terminal ;进入全局配置模式

  switch(config)#hostname ;设置交换机的主机名

  switch(config)#enable secret xxx ;设置特权加密口令

  switch(config)#enable password xxa ;设置特权非密口令

  switch(config)#line console 0 ;进入控制台口

  switch(config-line)#line vty 0 4 ;进入虚拟终端

  switch(config-line)#login ;允许登录

  switch(config-line)#password xx ;设置登录口令xx

  switch#exit ;返回命令

  交换机VLAN设置:

  switch#vlan database ;进入VLAN设置

  switch(vlan)#vlan 2 ;建VLAN 2

  switch(vlan)#no vlan 2 ;删vlan 2

  switch(config)#int f0/1 ;进入端口1

  switch(config-if)#switchport access vlan 2 ;当前端口加入vlan 2

  switch(config-if)#switchport mode trunk ;设置为干线

  switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的vlan

  switch(config-if)#switchport trunk encap dot1q ;设置vlan 中继

  switch(config)#vtp domain ;设置发vtp域名

  switch(config)#vtp password ;设置发vtp密码

  switch(config)#vtp mode server ;设置发vtp模式

  switch(config)#vtp mode client ;设置发vtp模式

  交换机设置IP地址:

  switch(config)#interface vlan 1 ;进入vlan 1

  switch(config-if)#ip address ;设置IP地址

  switch(config)#ip default-gateway ;设置默认网关

  switch(config)#no shutdown

  switch#dir flash: ;查看闪存

  交换机显示命令:

  switch#write ;保存配置信息

  switch#show vtp ;查看vtp配置信息

  switch#show run ;查看当前配置信息

  switch#show vlan ;查看vlan配置信息

  switch#show interface ;查看端口信息

  switch#show int f0/0 ;查看指定端口信息

  3. 路由器支持的命令:

  路由器显示命令:

  router#show run ;显示配置信息

  router#show interface ;显示接口信息

  router#show ip route ;显示路由信息

  router#show cdp nei ;显示邻居信息

  router#reload     ;重新起动

  路由器口令设置:

  router>enable ;进入特权模式

  router#config terminal ;进入全局配置模式

  router(config)#hostname ;设置交换机的主机名

  router(config)#enable secret xxx ;设置特权加密口令

  router(config)#enable password xxb ;设置特权非密口令

  router(config)#line console 0 ;进入控制台口

  router(config-line)#line vty 0 4 ;进入虚拟终端

  router(config-line)#login ;要求口令验证

  router(config-line)#password xx ;设置登录口令xx

  router(config)#(Ctrl+z) ; 返回特权模式

  router#exit ;返回命令

  路由器配置:

  router(config)#int s0/0 ;进入Serail接口

  router(config-if)#no shutdown ;激活当前接口

  router(config-if)#clock rate 64000 ;设置同步时钟

  router(config-if)#ip address ;设置IP地址

  router(config-if)#ip address second ;设置第二个IP

  router(config-if)#int f0/0.1 ;进入子接口

  router(config-***if.1)#ip address ;设置子接口IP

  router(config-***if.1)#encapsulation dot1q ;绑定vlan中继协议

  router(config)#config-register 0x2142 ;跳过配置文件

  router(config)#config-register 0x2102 ;正常使用配置文件

  router#reload ;重新引导

  路由器文件操作:

  router#copy running-config startup-config ;保存配置

  router#copy running-config tftp ;保存配置到tftp

  router#copy startup-config tftp ;开机配置存到tftp

  router#copy tftp flash: ;下传文件到flash

  router#copy tftp startup-config ;下载配置文件

  ROM状态:

  Ctrl+Break ;进入ROM监控状态

  rommon>confreg 0x2142 ;跳过配置文件

  rommon>confreg 0x2102 ;恢复配置文件

  rommon>reset ;重新引导

  rommon>copy xmodem: flash: ;从console传输文件

原创文章,作者:亿百科,如若转载,请注明出处:https://www.52vmi.cn/311383.html